TaleBlazer TaleBlazer

System Requirements

Mobile Requirements


Mobile devices must be equipped with enabled GPS positioning technology.

Sufficient storage to cache game images and videos must be available. At least 50MB is recommended.


iOS version 6.0 or higher is required.


Android version 4.0 or higher is required.

Google Maps API must be bundled with OS

Editor Requirements

TaleBlazer is expected to work on all modern browsers, but here is a list of browsers we test with.
  • Firefox 9 or later
  • Safari 5 or later
  • Chrome